Exchange: Delivery has failed to these recipients or distribution lists – IMCEAMAILTO

Clicked a link to email somebody outside the organisation, Outlook 2007 opened a new mail window as you’d expect. Typed the message, clicked Send, and immediately got a message back from Exchange (2007):

Delivery has failed to these recipients or distribution lists:

‘firstname.lastname@hp.com’
A problem occurred during the delivery of this message. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message later, or provide the following diagnostic text to your system administrator.
————————————————-
Sent by Microsoft Exchange Server 2007
Diagnostic information for administrators:
Generating server:hubtransportserver.active.directory.mydomain.co.uk
IMCEAMAILTO-firstname+2Elastname+40hp+2Ecom@mydomain.co.uk
#550 5.4.4 ROUTING.NoNextHop; unable to route ##
Original message headers:
Received: from mailboxserver.active.directory.mydomain.co.uk ([zzzz::zzzz:zzzz:zzz:zzzz]) by  hubtransportserver.active.directory.mydomain.co.uk ([192.168.251.45]) with mapi; Thu, 28 Oct  2010 11:09:40 +0100
Content-Type: application/ms-tnef; name=”winmail.dat”
Content-Transfer-Encoding: binary
From: Me me@mydomain.co.uk
To: “‘firstname.lastname@hp.com’” IMCEAMAILTO-firstname+2Elastname+40hp+2Ecom@mydomain.co.uk
Date: Thu, 28 Oct 2010 11:09:39 +0100
Subject: Something Amazing
Thread-Topic: Something Amazing
Thread-Index: xxxxxxxxxxxxxxxxxxxxxxxx
Message-ID: yyyyyyyyyyyyyyyyyyyyyyyyy@mailboxserver.active.directory.mydomain.co.uk
Accept-Language: en-US, en-GB
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator: yyyyyyyyyyyyyyyyyyyyyyyyy@mailboxserver.active.directory.mydomain.co.uk
MIME-Version: 1.0

…which was nice.

Tried to send the message again, this time by typing the email address into the To box manually, same error message back from Exchange.
Opened a new email, typed the address into the To field, double-clicked the address once Outlook had underlined it and checked the E-Mail address field – it looked fine, correctly contained the email address that I was trying to send to.
I then tried this to a different external email address that I know I can send mail to and compared the two E-mail Properties boxes:
Not working:
Working:
Spot the (important) difference? On the properties for the address that doesn’t work the E-mail type field is set to MAILTO, whereas it should be set to SMTP and greyed out, as in the bottom picture. Clicking the Internet Type button corrects this, and then the message will send fine.
This is ultimately caused because the original link I clicked had a malformed mailto URL on the email address, which I didn’t notice at the time, as per here.
About these ads
This entry was posted in Applications, Exchange, Outlook and tagged , , , , , , . Bookmark the permalink.

20 Responses to Exchange: Delivery has failed to these recipients or distribution lists – IMCEAMAILTO

  1. Sohail says:

    Perfect .. this worked for me

  2. Mike says:

    Thank you! This one was a real puzzler until I found your article.

  3. Miroslav says:

    Nice work, thx for your post … Worked for me to :)

  4. sideswipe79 says:

    Worked perfectly for me. Thanks a lot

  5. Thanks, I had this problem earlier. Did a google search of the error, your page popped up. Had it fixed in two minutes and my user is very happy.

  6. timmay333 says:

    Had this issue with outlook 2010, great solution. Do we have to do this all the time? or is this a one time deal?

  7. SRF says:

    Hi,
    I search for this error, and i find your page.
    This worked very nice.
    Thanks.

  8. Jason Prahl says:

    Fantastic! Totally fixed my problem.

  9. Pingback: Jason Prahl's Blog » Blog Archive » Exchange 2007 routing NoNextHop, unable to route error

  10. Victor says:

    So good!! Solved my problem.

  11. Reijndert says:

    This solved our problem. Thanks so much. I can even replicate this problem now.

  12. Darrin says:

    Thanks was this very useful. I used to get them to remove it from the auto-complete list (nickname file) but this is better. Great work.

  13. Donna says:

    Thank you very much for this – a whole week has gone by and three techs have being trying to figuer this out. I get hold of it and within two minutes I fix it – all because you are a genius and they obviously do not know how to use Google !!! :)

  14. patrickhoban says:

    I had the same issue in Outlook 2010. Your post was the light bulb that got me going in the right direction. I’ll post more details on my blog when I have a moment. Thanks

    http://patrickhoban.wordpress.com

  15. Mike says:

    A novice to Exchange. How do I display the email properties you have included in this post?

    • rcmtech says:

      It varies for different versions of Outlook. I’d suggest a web search for “display email header outlook xxxx” where xxxx is your version of Outlook.

  16. Chris says:

    Worked like a charm. Thanks for the info!

  17. Ahmed says:

    Great.. I just tried it on a user and it worked..

    Thanks to you

  18. Pingback: [MS Office - 2010] IMCEAMAILTO Issues when replying to forwarded message - Page 2

  19. izislav says:

    спасибо , помогло !

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s